What’s Vulnerable › Vulnerabilities
CVE-2026-39304: Apache ActiveMQ Client, Apache ActiveMQ Broker, Apache ActiveMQ All, Apache ActiveMQ: Incorrect handling of TLSv1.3 KeyUpdate can be exploited to cause DoS via OOM
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-04-10 · updated 2026-10-26
- Weakness: CWE-400
Description
Denial of Service via Out of Memory vulnerability in Apache ActiveMQ Client, Apache ActiveMQ Broker, Apache ActiveMQ. ActiveMQ NIO SSL transports do not correctly handle TLSv1.3 handshake KeyUpdates triggered by clients. This makes it possible for a client to rapidly trigger updates which causes the broker to exhaust all its memory in the SSL engine leading to DoS. Note: TLS versions before TLSv1.3 (such as TLSv1.2) are broken but are not vulnerable to OOM. Previous TLS versions require a full handshake renegotiation which causes a connection to hang but not OOM. This is fixed as well. This issue affects Apache ActiveMQ Client: before 5.19.4, from 6.0.0 before 6.2.4; Apache ActiveMQ Broker: before 5.19.4, from 6.0.0 before 6.2.4; Apache ActiveMQ: before 5.19.4, from 6.0.0 before 6.2.4. Users are recommended to upgrade to version 6.2.4 or 5.19.5, which fixes the issue.
Affected products
- Apache ActiveMQ: before 5.19.4; from 6.0.0 before 6.2.4 — fixed in 5.19.4, 6.2.4
- Apache Activemq Broker: before 5.19.4; from 6.0.0 before 6.2.4 — fixed in 5.19.4, 6.2.4
How to fix
Upgrade to a fixed version: Apache ActiveMQ 5.19.4, 6.2.4; Apache Activemq Broker 5.19.4, 6.2.4. Check the vendor advisory for mitigations.
References
- https://activemq.apache.org/security-advisories.data/CVE-2026-39304-announcement.txt
- http://www.openwall.com/lists/oss-security/2026/04/09/17
- https://access.redhat.com/security/cve/CVE-2026-39304
- https://bugzilla.redhat.com/show_bug.cgi?id=2457275
- https://security.access.redhat.com/data/csaf/v2/vex/2026/cve-2026-39304.json
Get alerted when CVE-2026-39304 or the next vulnerability affects your stack