What’s Vulnerable › Vulnerabilities
CVE-2026-39332: ChurchCRM has Reflected Cross-Site Scripting (XSS) in GeoPage.php
- Severity: high (CVSS 8.7 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-04-07 · updated 2026-10-26
- Weakness: CWE-79
Description
ChurchCRM is an open-source church management system. Prior to 7.1.0, a reflected Cross-Site Scripting (XSS) vulnerability in GeoPage.php allows any authenticated user to inject arbitrary JavaScript into the browser of another authenticated user. Because the payload fires automatically via autofocus with no user interaction required, an attacker can steal session cookies and fully take over any victim account, including administrator accounts, by tricking them into submitting a crafted form. This vulnerability is fixed in 7.1.0.
Affected products
- ChurchCRM CRM: before 7.1.0 — fixed in 7.1.0
How to fix
Upgrade to a fixed version: ChurchCRM CRM 7.1.0. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-39332 or the next vulnerability affects your stack