What’s Vulnerable › Vulnerabilities
CVE-2026-39337: ChurchCRM Affected by Unauthenticated RCE in Install Wizard
- Severity: critical (CVSS 10.0 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-04-07 · updated 2026-10-26
- Weakness: CWE-94
Description
ChurchCRM is an open-source church management system. Prior to 7.1.0, critical pre-authentication remote code execution vulnerability in ChurchCRM's setup wizard allows unauthenticated attackers to inject arbitrary PHP code during the initial installation process, leading to complete server compromise. The "$dbPassword" variable is not sanitized. This vulnerability exists due to an incomplete fix for CVE-2025-62521. This vulnerability is fixed in 7.1.0.
Affected products
- ChurchCRM CRM: before 7.1.0 — fixed in 7.1.0
How to fix
Upgrade to a fixed version: ChurchCRM CRM 7.1.0. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-39337 or the next vulnerability affects your stack