What’s Vulnerable › Vulnerabilities
CVE-2026-39381: Parse Server's Endpoint `/sessions/me` bypasses `_Session` `protectedFields`
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-04-07 · updated 2026-07-24
- Weakness: CWE-863
Description
Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. Prior to 9.8.0-alpha.7 and 8.6.75, the GET /sessions/me endpoint returns _Session fields that the server operator explicitly configured as protected via the protectedFields server option. Any authenticated user can retrieve their own session's protected fields with a single request. The equivalent GET /sessions and GET /sessions/:objectId endpoints correctly strip protected fields. This vulnerability is fixed in 9.8.0-alpha.7 and 8.6.75.
Affected products
- parse-community parse-server: before 8.6.75; from 9.0.0 before 9.8.0; 9.8.0-alpha1, 9.8.0-alpha2, 9.8.0-alpha3, 9.8.0-alpha4, 9.8.0-alpha5, 9.8.0-alpha6 — fixed in 8.6.75, 9.8.0
How to fix
Upgrade to a fixed version: parse-community parse-server 8.6.75, 9.8.0. Check the vendor advisory for mitigations.
References
- https://github.com/parse-community/parse-server/pull/10406
- https://github.com/parse-community/parse-server/pull/10407
- https://github.com/parse-community/parse-server/security/advisories/GHSA-g4v2-qx3q-4p64
Get alerted when CVE-2026-39381 or the next vulnerability affects your stack