What’s Vulnerable › Vulnerabilities
CVE-2026-39397: @delmaredigital/payload-puc is missing authorization on /api/puck/* CRUD endpoints allows unauthenticated access to Puck-registered collections
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2026-04-07 · updated 2026-07-24
- Weakness: CWE-862
Description
@delmaredigital/payload-puck is a PayloadCMS plugin for integrating Puck visual page builder. Prior to 0.6.23, all /api/puck/* CRUD endpoint handlers registered by createPuckPlugin() called Payload's local API with the default overrideAccess: true, bypassing all collection-level access control. The access option passed to createPuckPlugin() and any access rules defined on Puck-registered collections were silently ignored on these endpoints. This vulnerability is fixed in 0.6.23.
Affected products
- delmaredigital payload-puck: before 0.6.23 — fixed in 0.6.23
How to fix
Upgrade to a fixed version: delmaredigital payload-puck 0.6.23. Check the vendor advisory for mitigations.
References
- https://github.com/delmaredigital/payload-puck/commit/9148201c6bbfa140d44546438027a2f8a70f79a4
- https://github.com/delmaredigital/payload-puck/issues/7
- https://github.com/delmaredigital/payload-puck/security/advisories/GHSA-65w6-pf7x-5g85
Get alerted when CVE-2026-39397 or the next vulnerability affects your stack