What’s Vulnerable › Vulnerabilities
CVE-2026-39411: LobeHub has an unauthenticated authentication bypass on `webapi` routes via forgeable `X-lobe-chat-auth` header
- Severity: high (CVSS 7.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-04-08 · updated 2026-07-24
- Weakness: CWE-287
Description
LobeHub is a work-and-lifestyle space to find, build, and collaborate with agent teammates that grow with you. Prior to 2.1.48, the webapi authentication layer trusts a client-controlled X-lobe-chat-auth header that is only XOR-obfuscated, not signed or otherwise authenticated. Because the XOR key is hardcoded in the repository, an attacker can forge arbitrary auth payloads and bypass authentication on protected webapi routes. Affected routes include /webapi/chat/[provider], /webapi/models/[provider], /webapi/models/[provider]/pull, and /webapi/create-image/comfyui. This vulnerability is fixed in 2.1.48.
Affected products
- lobehub: before 2.1.48 — fixed in 2.1.48
How to fix
Upgrade to a fixed version: lobehub 2.1.48. Check the vendor advisory for mitigations.
References
- https://github.com/lobehub/lobehub/commit/3327b293d66c013f076cbc16cdbd05a61a3d0428
- https://github.com/lobehub/lobehub/pull/13535
- https://github.com/lobehub/lobehub/releases/tag/v2.1.48
- https://github.com/lobehub/lobehub/security/advisories/GHSA-5mwj-v5jw-5c97
- https://github.com/lobehub/lobehub/security/advisories/GHSA-5mwj-v5jw-5c97
Get alerted when CVE-2026-39411 or the next vulnerability affects your stack