What’s Vulnerable › Vulnerabilities
CVE-2026-39422: MaxKB has Stored XSS via ChatHeadersMiddleware
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2026-04-14 · updated 2026-10-26
- Weakness: CWE-79
Description
MaxKB is an open-source AI assistant for enterprise. Versions 2.7.1 and below contain a Stored Cross-Site Scripting (XSS) vulnerability through the application name or icon fields when creating an application. When a victim visits the public chat interface (/ui/chat/{access_token}), the ChatHeadersMiddleware retrieves the application data and directly inserts the unescaped application name and icon into the HTML response via string replacement. This allows an attacker to execute arbitrary JavaScript in the victim's browser context. This issue has been fixed in version 2.8.0.
Affected products
- 1Panel-dev MaxKB: before 2.8.0 — fixed in 2.8.0
How to fix
Upgrade to a fixed version: 1Panel-dev MaxKB 2.8.0. Check the vendor advisory for mitigations.
References
- https://github.com/1Panel-dev/MaxKB/commit/026a2d623e2aa5efa67c4834651e79d5d7cab1da
- https://github.com/1Panel-dev/MaxKB/releases/tag/v2.8.0
- https://github.com/1Panel-dev/MaxKB/security/advisories/GHSA-wf7p-3jq5-q52w
- https://github.com/1Panel-dev/MaxKB/security/advisories/GHSA-wf7p-3jq5-q52w
Get alerted when CVE-2026-39422 or the next vulnerability affects your stack