What’s Vulnerable › Vulnerabilities
CVE-2026-39816: Apache NiFi: Missing Execute Code Required Permission on TinkerpopClientService
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-05-08 · updated 2026-10-26
- Weakness: CWE-862
Description
The optional extension component TinkerpopClientService is missing the Restricted annotation with the Execute Code Required Permission in Apache NiFi 2.0.0-M1 through 2.8.0. The TinkerpopClientService supports configuration of ByteCode Submission for the Script Submission Type, enabling Groovy Script execution in the service prior to submitting the query. The missing Restricted annotation allows users without the Execute Code Permission to configure the Service in installations that use fine-grained authorization and have the optional TinkerpopClientService installed. Apache NiFi installations that do not have the nifi-other-graph-services-nar installed are not subject to this vulnerability. Upgrading to Apache NiFi 2.9.0 is the recommended mitigation.
Affected products
- Apache Software Foundation Apache NiFi: from 2.0.0 before 2.9.0 — fixed in 2.9.0
How to fix
Upgrade to a fixed version: Apache Software Foundation Apache NiFi 2.9.0. Check the vendor advisory for mitigations.
References
- https://lists.apache.org/thread/gh9g7xwvv4l20gzff6q3367snf35ctcb
- http://www.openwall.com/lists/oss-security/2026/04/13/8
- https://zeropath.com/blog/nifi-cve-2026-39816-privesc-rce
Get alerted when CVE-2026-39816 or the next vulnerability affects your stack