What’s Vulnerable › Vulnerabilities
CVE-2026-39838: ProofreadPage improperly sanitizes multiline styles using Sanitizer::checkCSS
- Severity: medium (CVSS 6.9 v4.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-04-07 · updated 2026-07-21
- Weakness: CWE-79
Description
Improper neutralization of input during web page generation ('cross-site scripting') vulnerability in Wikimedia Foundation MediaWiki - ProofreadPage Extension allows XSS Targeting Non-Script Elements. The issue has been remediated on the `master` branch, and in the release branches for MediaWiki versions 1.43, 1.44, and 1.45.
Affected products
- Wikimedia Foundation MediaWiki - ProofreadPage Extension: before 1.43 — fixed in 1.43
How to fix
Upgrade to a fixed version: Wikimedia Foundation MediaWiki - ProofreadPage Extension 1.43. Check the vendor advisory for mitigations.
References
- https://gerrit.wikimedia.org/r/q/Idd51e18479b32b7176b43ff74ca1c49d6bdd0628
- https://phabricator.wikimedia.org/T406088
Get alerted when CVE-2026-39838 or the next vulnerability affects your stack