What’s Vulnerable › Vulnerabilities
CVE-2026-39863: Kamailio Core: TCP Data Processing Vulnerability
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-04-08 · updated 2026-07-24
- Weakness: CWE-119
Description
Kamailio is an open source implementation of a SIP Signaling Server. Prior to 6.1.1, 6.0.6, and 5.8.8, an out-of-bounds access in the core of Kamailio (formerly OpenSER and SER) allows remote attackers to cause a denial of service (process crash) via a specially crafted data packet sent over TCP. The issue impacts Kamailio instances having TCP or TLS listeners. This vulnerability is fixed in 5.1.1, 6.0.6, and 5.8.8.
Affected products
- Kamailio: before 5.8.8; from 6.0.0 before 6.0.6; 6.1.0 — fixed in 5.8.8, 6.0.6
How to fix
Upgrade to a fixed version: Kamailio 5.8.8, 6.0.6. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-39863 or the next vulnerability affects your stack