What’s Vulnerable › Vulnerabilities
CVE-2026-39881: Vim Ex command injection in Vims NetBeans integration
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-04-08 · updated 2026-07-24
- Weakness: CWE-94
Description
Vim is an open source, command line text editor. Prior to 9.2.0316, a command injection vulnerability in Vim's netbeans interface allows a malicious netbeans server to execute arbitrary Ex commands when Vim connects to it, via unsanitized strings in the defineAnnoType and specialKeys protocol messages. This vulnerability is fixed in 9.2.0316.
Affected products
- vim/vim: before 9.2.0316 — fixed in 9.2.0316
How to fix
Upgrade to a fixed version: vim/vim 9.2.0316. Check the vendor advisory for mitigations.
References
- https://github.com/vim/vim/commit/7ab76a86048ed492374ac6b19
- https://github.com/vim/vim/releases/tag/v9.2.0316
- https://github.com/vim/vim/security/advisories/GHSA-mr87-rhgv-7pw6
Get alerted when CVE-2026-39881 or the next vulnerability affects your stack