What’s Vulnerable › Vulnerabilities
CVE-2026-39892: cryptography has a buffer overflow if non-contiguous buffers were passed to APIs
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-04-08 · updated 2026-09-10
- Weakness: CWE-119
Description
cryptography is a package designed to expose cryptographic primitives and recipes to Python developers. From 45.0.0 to before 46.0.7, if a non-contiguous buffer was passed to APIs which accepted Python buffers (e.g. Hash.update()), this could lead to buffer overflows. This vulnerability is fixed in 46.0.7.
Affected products
- pyca cryptography: from 45.0.0 before 46.0.7 — fixed in 46.0.7
How to fix
Upgrade to a fixed version: pyca cryptography 46.0.7. Check the vendor advisory for mitigations.
References
- https://github.com/pyca/cryptography/security/advisories/GHSA-p423-j2cm-9vmq
- http://www.openwall.com/lists/oss-security/2026/04/08/12
- https://access.redhat.com/errata/RHSA-2026:19375
- https://access.redhat.com/errata/RHSA-2026:20338
- https://access.redhat.com/errata/RHSA-2026:21017
- https://access.redhat.com/errata/RHSA-2026:22465
- https://access.redhat.com/errata/RHSA-2026:22629
- https://access.redhat.com/errata/RHSA-2026:22840
- https://access.redhat.com/errata/RHSA-2026:23361
- https://access.redhat.com/errata/RHSA-2026:24483
- https://access.redhat.com/errata/RHSA-2026:24761
- https://access.redhat.com/errata/RHSA-2026:24762
Get alerted when CVE-2026-39892 or the next vulnerability affects your stack