What’s Vulnerable › Vulnerabilities
CVE-2026-39897: Cacti has a Reflected XSS Vulnerability via html_auth_footer
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-06-24 · updated 2026-06-25
- Weakness: CWE-79
Description
Cacti is an open source performance and fault management framework. Versions 1.2.30 and below contain a Reflected XSS vulnerability in the html_auth_footer. This issue has been fixed in version 1.2.31.
Affected products
- cacti: before 1.2.31 — fixed in 1.2.31
How to fix
Upgrade to a fixed version: cacti 1.2.31. Check the vendor advisory for mitigations.
References
- https://github.com/Cacti/cacti/commit/7c544ea0b45de627f206eefe93005433c2c3864d
- https://github.com/Cacti/cacti/security/advisories/GHSA-2j98-xfjq-gw39
Get alerted when CVE-2026-39897 or the next vulnerability affects your stack