What’s Vulnerable › Vulnerabilities
CVE-2026-39919: Ghostscript < 10.08.0 Heap Buffer Overflow via JPEG 2000 Output Adapter
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-09-15 · updated 2026-09-24
- Weakness: CWE-122
Description
Ghostscript before 10.08.0 contains a heap-based buffer overflow vulnerability in the JPEG 2000 output adapter (base/sjpx_openjpeg.c) that allows attackers to cause memory corruption by supplying a crafted PDF containing a JPEG 2000 image with mismatched component subsampling factors. When image components declare different subsampling values, the non-samescale sub-byte-depth output path allocates a row buffer sized for packed output but writes a full byte per output column regardless of bit depth, overflowing the allocation and corrupting internal chunk-allocator metadata to achieve code execution.
Affected products
- Artifex Software ghostscript: before 10.08.0 — fixed in 10.08.0
How to fix
Upgrade to a fixed version: Artifex Software ghostscript 10.08.0. Check the vendor advisory for mitigations.
References
- https://bugs.ghostscript.com/show_bug.cgi?id=709666
- https://github.com/ArtifexSoftware/ghostpdl-downloads/releases/tag/gs10080
- https://github.com/ArtifexSoftware/ghostpdl/commit/0a8bf88e39db07b0751a58d6ec1cf992073e4dc1
- https://www.vulncheck.com/advisories/ghostscript-heap-buffer-overflow-via-jpeg-2000-output-adapter
Get alerted when CVE-2026-39919 or the next vulnerability affects your stack