What’s Vulnerable › Vulnerabilities
CVE-2026-39921: GeoNode < 4.4.5, 5.0.2 SSRF via Document Upload
- Severity: medium (CVSS 6.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-04-10 · updated 2026-07-14
- Weakness: CWE-918
Description
GeoNode versions 4.0 before 4.4.5 and 5.0 before 5.0.2 contain a server-side request forgery vulnerability that allows authenticated users with document upload permissions to trigger arbitrary outbound HTTP requests by providing a malicious URL via the doc_url parameter during document upload. Attackers can supply URLs pointing to internal network targets, loopback addresses, RFC1918 addresses, or cloud metadata services to cause the server to make requests to internal resources without SSRF mitigations such as private IP filtering or redirect validation.
Affected products
- geonode: from 4.0.0 before 4.4.5; from 5.0.0 before 5.0.2 — fixed in 4.4.5, 5.0.2
How to fix
Upgrade to a fixed version: geonode 4.4.5, 5.0.2. Check the vendor advisory for mitigations.
References
- https://github.com/GeoNode/geonode/commit/4a852cfc1da732b10779b5bf5f087c8f02985571
- https://github.com/GeoNode/geonode/commit/9856cb5ab27e33c0adba9274f4cccf6d1f534bd1
- https://github.com/GeoNode/geonode/pull/14058
- https://github.com/GeoNode/geonode/releases/tag/4.4.5
- https://github.com/GeoNode/geonode/releases/tag/5.0.2
- https://www.vulncheck.com/advisories/geonode-ssrf-via-document-upload
Get alerted when CVE-2026-39921 or the next vulnerability affects your stack