What’s Vulnerable › Vulnerabilities
CVE-2026-39922: GeoNode SSRF via Service Registration
- Severity: medium (CVSS 6.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-04-10 · updated 2026-10-08
- Weakness: CWE-918
Description
GeoNode versions 4.4.5 and 5.0.2 (and prior within their respective releases) contain a server-side request forgery vulnerability in the service registration endpoint that allows authenticated attackers to trigger outbound network requests to arbitrary URLs by submitting a crafted service URL during form validation. Attackers can probe internal network targets including loopback addresses, RFC1918 private IP ranges, link-local addresses, and cloud metadata services by exploiting insufficient URL validation in the WMS service handler without private IP filtering or allowlist enforcement.
Affected products
- geonode: from 4.0.0 before 4.4.5; from 5.0.0 before 5.0.2 — fixed in 4.4.5, 5.0.2
How to fix
Upgrade to a fixed version: geonode 4.4.5, 5.0.2. Check the vendor advisory for mitigations.
References
- https://github.com/GeoNode/geonode/security/advisories/GHSA-hw9r-6m78-w6h3
- https://www.vulncheck.com/advisories/geonode-ssrf-via-service-registration
Get alerted when CVE-2026-39922 or the next vulnerability affects your stack