What’s Vulnerable › Vulnerabilities
CVE-2026-39938: Cacti: Unauthenticated RCE on Graph Image
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-06-24 · updated 2026-06-26
- Weakness: CWE-22
Description
Cacti is an open source performance and fault management framework. Versions 1.2.30 and prior have unauthenticated LFI through graph_theme and rrdtool IPC serialization hardening. This issue has been resolved in version 1.2.31.
Affected products
- cacti: before 1.2.31 — fixed in 1.2.31
How to fix
Upgrade to a fixed version: cacti 1.2.31. Check the vendor advisory for mitigations.
References
- https://github.com/Cacti/cacti/commit/9871f0cef9af285398d558c9b3188d5977e01a04
- https://github.com/Cacti/cacti/security/advisories/GHSA-rm7p-qcqm-x5m6
Get alerted when CVE-2026-39938 or the next vulnerability affects your stack