What’s Vulnerable › Vulnerabilities
CVE-2026-39979: jq: Out-of-Bounds Read in jv_parse_sized() Error Formatting for Non-NUL-Terminated Counted Buffers
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2026-04-13 · updated 2026-10-26
- Weakness: CWE-125
Description
jq is a command-line JSON processor. In commits before 2f09060afab23fe9390cce7cb860b10416e1bf5f, the jv_parse_sized() API in libjq accepts a counted buffer with an explicit length parameter, but its error-handling path formats the input buffer using %s in jv_string_fmt(), which reads until a NUL terminator is found rather than respecting the caller-supplied length. This means that when malformed JSON is passed in a non-NUL-terminated buffer, the error construction logic performs an out-of-bounds read past the end of the buffer. The vulnerability is reachable by any libjq consumer calling jv_parse_sized() with untrusted input, and depending on memory layout, can result in memory disclosure or process termination. The issue has been patched in commit 2f09060afab23fe9390cce7cb860b10416e1bf5f.
Affected products
- jqlang jq: before 1.8.2 — fixed in 1.8.2
- Red Hat AI Inference Server: from 3.2.0 before 3.2.2; from 3.3.0 before 3.3.5 — fixed in 3.2.2, 3.3.5
- Red Hat Ansible Automation Platform: 2.0
- Red Hat Ceph Storage: 4.0
- RedHat Codeready Linux Builder: 8.0, 9.0, 10.0
- RedHat Codeready Linux Builder Eus: 9.4, 9.6, 10.0
- Red Hat Enterprise Linux: 8.0, 9.0, 10.0
- RedHat Enterprise Linux Aus: 8.4, 8.6
- RedHat Enterprise Linux Eus: 8.4, 9.4, 9.6, 10.0
- RedHat Enterprise Linux Tus: 8.6, 8.8
- RedHat Enterprise Linux Update Services For Sap Solutions: 8.6, 8.8, 9.0, 9.2
- RedHat Hardened Images: all versions
- Red Hat OpenShift AI 2.25: from 3.4 before 3.4.3 — fixed in 3.4.3
- Red Hat OpenShift Container Platform 4.18: from 4.12 before 4.12.92; from 4.13 before 4.13.68; from 4.14 before 4.14.68; from 4.15 before 4.15.65; from 4.16 before 4.16.64; from 4.17 before 4.17.55 — fixed in 4.12.92, 4.13.68, 4.14.68, 4.15.65, 4.16.64, 4.17.55
How to fix
Upgrade to a fixed version: jqlang jq 1.8.2; Red Hat AI Inference Server 3.2.2, 3.3.5; Red Hat OpenShift AI 2.25 3.4.3; Red Hat OpenShift Container Platform 4.18 4.12.92, 4.13.68, 4.14.68, 4.15.65. Check the vendor advisory for mitigations.
References
- https://github.com/jqlang/jq/commit/2f09060afab23fe9390cce7cb860b10416e1bf5f
- https://github.com/jqlang/jq/security/advisories/GHSA-2hhh-px8h-355p
- https://access.redhat.com/errata/RHSA-2026:16252
- https://access.redhat.com/errata/RHSA-2026:16692
- https://access.redhat.com/errata/RHSA-2026:16693
- https://access.redhat.com/errata/RHSA-2026:18040
- https://access.redhat.com/errata/RHSA-2026:18042
- https://access.redhat.com/errata/RHSA-2026:18043
- https://access.redhat.com/errata/RHSA-2026:18044
- https://access.redhat.com/errata/RHSA-2026:18045
- https://access.redhat.com/errata/RHSA-2026:18046
- https://access.redhat.com/errata/RHSA-2026:18047
Get alerted when CVE-2026-39979 or the next vulnerability affects your stack