What’s Vulnerable › Vulnerabilities
CVE-2026-39980: OpenCTI affected by RCE via notifier template
- Severity: high (CVSS 7.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-04-09 · updated 2026-06-17
- Weakness: CWE-1336
Description
OpenCTI is an open source platform for managing cyber threat intelligence knowledge and observables. Prior to 6.9.5, the safeEjs.ts file does not properly sanitize EJS templates. Users with the Manage customization capability can run arbitrary JavaScript in the context of the OpenCTI platform process during notifier template execution. This vulnerability is fixed in 6.9.5.
Affected products
- OpenCTI-Platform opencti: before 6.9.5 — fixed in 6.9.5
How to fix
Upgrade to a fixed version: OpenCTI-Platform opencti 6.9.5. Check the vendor advisory for mitigations.
In the news
References
- https://github.com/OpenCTI-Platform/opencti/releases/tag/6.9.5
- https://github.com/OpenCTI-Platform/opencti/security/advisories/GHSA-jv9r-jw2f-rhrf
Get alerted when CVE-2026-39980 or the next vulnerability affects your stack