What’s Vulnerable › Vulnerabilities
CVE-2026-39998: Apache APISIX: Identity Injection via forward-auth Plugin Missing Header Cleanup
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-06-19 · updated 2026-10-26
- Weakness: CWE-20
Description
Improper Input Validation vulnerability in Apache APISIX. The attacker can take advantage of certain configuration in forward-auth plugin to spoof identity headers. This issue affects Apache APISIX: from 2.12.0 through 3.16.0. Users are recommended to upgrade to version 3.17.0, which fixes the issue.
Affected products
- Apache Software Foundation Apache APISIX: from 2.12.0 before 3.17.0 — fixed in 3.17.0
How to fix
Upgrade to a fixed version: Apache Software Foundation Apache APISIX 3.17.0. Check the vendor advisory for mitigations.
References
- https://lists.apache.org/thread/vgkvy396010d7g6m0jrn4d3hjf2svlvv
- http://www.openwall.com/lists/oss-security/2026/06/19/4
Get alerted when CVE-2026-39998 or the next vulnerability affects your stack