What’s Vulnerable › Vulnerabilities
CVE-2026-39999: Apache APISIX: JWT Algorithm Confusion allows authentication bypass
- Severity: critical (CVSS 9.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-06-19 · updated 2026-10-25
- Weakness: CWE-290
Description
Authentication Bypass by Spoofing vulnerability in Apache APISIX. The attacker can completely bypass authentication capitalising on certain configurations of jwt-auth plugin. This issue affects Apache APISIX: from v2.2 through v3.16.0. Users are recommended to upgrade to version v3.17.0, which fixes the issue.
Affected products
- Apache Software Foundation Apache APISIX: from 2.2 before 3.17.0 — fixed in 3.17.0
How to fix
Upgrade to a fixed version: Apache Software Foundation Apache APISIX 3.17.0. Check the vendor advisory for mitigations.
References
- https://lists.apache.org/thread/nfopt8cnxd3k0rs1oxtr7lzxrdw4mojq
- http://www.openwall.com/lists/oss-security/2026/06/19/5
Get alerted when CVE-2026-39999 or the next vulnerability affects your stack