What’s Vulnerable › Vulnerabilities
CVE-2026-40010: Apache Wicket: possible session fixation using AuthenticatedWebSession
- Severity: critical (CVSS 9.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-05-06 · updated 2026-10-26
- Weakness: CWE-384
Description
Missing invocation of Servlet http web request method changeSessionId after session binding can be exploited for a session fixation attack in Apache Wicket. This issue affects Apache Wicket: from 8.0.0 through 8.17.0, 9.0.0, from 10.0.0 through 10.8.0. Users are recommended to upgrade to version 10.9.0, which fixes the issue.
Affected products
- Apache Software Foundation Apache Wicket: from 8.0.0 through 8.17.0; from 9.0.0 through 9.22.0; from 10.0.0 before 10.9.0 — fixed in 10.9.0
How to fix
Upgrade to a fixed version: Apache Software Foundation Apache Wicket 10.9.0. Check the vendor advisory for mitigations.
References
- https://lists.apache.org/thread/61wsc0xdtfd5oozojfx7by9w3jwgkmv1
- http://www.openwall.com/lists/oss-security/2026/05/06/1
Get alerted when CVE-2026-40010 or the next vulnerability affects your stack