What’s Vulnerable › Vulnerabilities
CVE-2026-40013
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-08-28 · updated 2026-09-03
- Weakness: CWE-124
Description
An attacker that has valid credentials can submit a Sieve script containing an extreme numeric literal, which causes an out-of-bounds write when the ManageSieve service compiles the script. This causes memory corruption and an observed crash of the ManageSieve process, resulting in denial of service for script management. This might be able to be used for remote code execution. Disable the ManageSieve service if users do not need remote Sieve script management. Update to non-vulnerable version. No publicly available exploits are known.
Affected products
- Open-Xchange GmbH OX Dovecot CE: from 2.3.0 before 2.4.5 — fixed in 2.4.5
- Open-Xchange GmbH OX Dovecot Pro: from 2.3.0 before 2.3.22.2; from 3.0.0 before 3.0.7; from 3.1.0 before 3.1.6 — fixed in 2.3.22.2, 3.0.7, 3.1.6
How to fix
Upgrade to a fixed version: Open-Xchange GmbH OX Dovecot CE 2.4.5; Open-Xchange GmbH OX Dovecot Pro 2.3.22.2, 3.0.7, 3.1.6. Check the vendor advisory for mitigations.
References
- https://documentation.open-xchange.com/dovecot/security/advisories/csaf/2026/oxdc-adv-2026-0003.json
Get alerted when CVE-2026-40013 or the next vulnerability affects your stack