What’s Vulnerable › Vulnerabilities
CVE-2026-40028: Hayabusa < 3.8.0 XSS via JSON Log Import
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-04-08 · updated 2026-07-24
- Weakness: CWE-79
Description
Hayabusa versions prior to 3.8.0 contain a cross-site scripting (XSS) vulnerability in its HTML report output that allows an attacker to execute arbitrary JavaScript when a user scans JSON-exported logs containing malicious content in the Computer field. An attacker can inject JavaScript into the Computer field of JSON logs that executes in the forensic examiner's browser session when viewing the generated HTML report, leading to information disclosure or code execution.
Affected products
- Yamato-Security hayabusa: before 3.8.0 — fixed in 3.8.0
How to fix
Upgrade to a fixed version: Yamato-Security hayabusa 3.8.0. Check the vendor advisory for mitigations.
References
- https://github.com/Yamato-Security/hayabusa/releases/tag/v3.8.0
- https://mobasi.ai/sentinel
- https://www.vulncheck.com/advisories/hayabusa-xss-via-json-log-import
Get alerted when CVE-2026-40028 or the next vulnerability affects your stack