What’s Vulnerable › Vulnerabilities
CVE-2026-40036: Unfurl < 2026.04 - Denial of Service via Unbounded zlib Decompression
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2026-04-08 · updated 2026-10-08
- Weakness: CWE-409
Description
Unfurl before 2026.04 contains an unbounded zlib decompression vulnerability in parse_compressed.py that allows remote attackers to cause denial of service. Attackers can submit highly compressed payloads via URL parameters to the /json/visjs endpoint that expand to gigabytes, exhausting server memory and crashing the service.
Affected products
- obsidianforensics unfurl: before 2026.04 — fixed in 2026.04
How to fix
Upgrade to a fixed version: obsidianforensics unfurl 2026.04. Check the vendor advisory for mitigations.
References
- https://github.com/obsidianforensics/unfurl/releases/tag/v2026.04
- https://github.com/obsidianforensics/unfurl/security/advisories/GHSA-h5qv-qjv4-pc5m
- https://www.vulncheck.com/advisories/dfir-unfurl-denial-of-service-via-unbounded-zlib-decompression
Get alerted when CVE-2026-40036 or the next vulnerability affects your stack