What’s Vulnerable › Vulnerabilities
CVE-2026-40079: Cacti: Command Injection via escape_command() no-op in RRDtool execution
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-06-25 · updated 2026-06-26
- Weakness: CWE-78
Description
Cacti is an open source performance and fault management framework. Versions 1.2.30 and prior are vulnerable to Command Injection due to lack of sanitization in the escape_command() function. The escape_command() function at lib/rrd.php is a no-op: it returns $command unchanged. The command line built by rrdtool_function_graph() is passed through this function and then to shell_exec($full_commandline). The risk is in __rrd_execute() where text_format values from graph templates (which may contain host variable substitutions) reach shell_exec without adequate escaping. This issue has been addressed in version 1.2.31.
Affected products
- cacti: before 1.2.31 — fixed in 1.2.31
How to fix
Upgrade to a fixed version: cacti 1.2.31. Check the vendor advisory for mitigations.
References
- https://github.com/Cacti/cacti/commit/4c09efaebf3a9faec66969d0b5c4aceaf397f37f
- https://github.com/Cacti/cacti/security/advisories/GHSA-xq98-376r-hv9j
Get alerted when CVE-2026-40079 or the next vulnerability affects your stack