What’s Vulnerable › Vulnerabilities
CVE-2026-40087: LangChain has incomplete f-string validation in prompt templates
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-04-09 · updated 2026-10-25
- Weakness: CWE-1336
Description
LangChain is a framework for building agents and LLM-powered applications. Prior to 0.3.84 and 1.2.28, LangChain's f-string prompt-template validation was incomplete in two respects. First, some prompt template classes accepted f-string templates and formatted them without enforcing the same attribute-access validation as PromptTemplate. In particular, DictPromptTemplate and ImagePromptTemplate could accept templates containing attribute access or indexing expressions and subsequently evaluate those expressions during formatting. Second, f-string validation based on parsed top-level field names did not reject nested replacement fields inside format specifiers. In this pattern, the nested replacement field appears in the format specifier rather than in the top-level field name. As a result, earlier validation based on parsed field names did not reject the template even though Python formatting would still attempt to resolve the nested expression at runtime. This vulnerability is fixed in 0.3.84 and 1.2.28.
Affected products
- langchain-ai langchain: before 0.3.84; from 1.0.0 before 1.2.28 — fixed in 0.3.84, 1.2.28
How to fix
Upgrade to a fixed version: langchain-ai langchain 0.3.84, 1.2.28. Check the vendor advisory for mitigations.
References
- https://github.com/langchain-ai/langchain/commit/6bab0ba3c12328008ddca3e0d54ff5a6151cd27b
- https://github.com/langchain-ai/langchain/commit/af2ed47c6f008cdd551f3c0d87db3774c8dfe258
- https://github.com/langchain-ai/langchain/pull/36612
- https://github.com/langchain-ai/langchain/pull/36613
- https://github.com/langchain-ai/langchain/releases/tag/langchain-core%3D%3D0.3.84
- https://github.com/langchain-ai/langchain/releases/tag/langchain-core%3D%3D1.2.28
- https://github.com/langchain-ai/langchain/security/advisories/GHSA-926x-3r5x-gfhw
Get alerted when CVE-2026-40087 or the next vulnerability affects your stack