What’s Vulnerable › Vulnerabilities
CVE-2026-40105: XWiki has Reflected Cross-Site Scripting (XSS) in its page history compare functionality
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2026-04-15 · updated 2026-10-26
- Weakness: CWE-80
Description
XWiki Platform is a generic wiki platform offering runtime services for applications built on top of it. Versions 10.4-rc-1, through 16.10.15, 17.0.0-rc-1, through 17.4.7 and 17.5.0-rc-1 through 17.10.0 contain a reflected cross-site scripting vulnerability (XSS) in the comparison view between revisions of a page allows executing JavaScript code in the user's browser. If the current user is an admin, this can not only affect the current user but also the confidentiality, integrity and availability of the whole XWiki instance. If developers are unable to update immediately, they can apply the patch manually to templates/changesdoc.vm in the deployed WAR.
Affected products
- xwiki-platform: from 10.4 before 16.10.16; from 17.0.0 before 17.4.8; from 17.5.0 before 17.10.1 — fixed in 16.10.16, 17.4.8, 17.10.1
How to fix
Upgrade to a fixed version: xwiki-platform 16.10.16, 17.4.8, 17.10.1. Check the vendor advisory for mitigations.
References
- https://github.com/xwiki/xwiki-platform/commit/3c8a2ec985641367015c2db937574fcd360c788c
- https://github.com/xwiki/xwiki-platform/security/advisories/GHSA-w4fj-87j5-f25c
- https://jira.xwiki.org/browse/XWIKI-23472
Get alerted when CVE-2026-40105 or the next vulnerability affects your stack