What’s Vulnerable › Vulnerabilities
CVE-2026-40155: Auth0 Next.js SDK has Improper Proxy Cache Lookup
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-04-17 · updated 2026-06-17
- Weakness: CWE-362
Description
The Auth0 Next.js SDK is a library for implementing user authentication in Next.js applications. In versions 4.12.0 through 4.17.1, simultaneous requests that trigger a nonce retry may cause the proxy cache fetcher to perform improper lookups for the token request results. Users are affected if their project uses both the vulnerable versions and the proxy handler /me/* and /my-org/* with DPoP enabled. This issue has been fixed in version 4.18.0.
Affected products
- auth0 nextjs-auth0: from 4.12.0 before 4.18.0 — fixed in 4.18.0
How to fix
Upgrade to a fixed version: auth0 nextjs-auth0 4.18.0. Check the vendor advisory for mitigations.
References
- https://github.com/auth0/nextjs-auth0/commit/98c36dc306970c2230ea1a32efef431d29b99978
- https://github.com/auth0/nextjs-auth0/releases/tag/v4.18.0
- https://github.com/auth0/nextjs-auth0/security/advisories/GHSA-xq8m-7c5p-c2r6
Get alerted when CVE-2026-40155 or the next vulnerability affects your stack