What’s Vulnerable › Vulnerabilities
CVE-2026-40169: ImageMagick: Heap buffer overflow (WRITE) in the YAML and JSON encoders
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-04-13 · updated 2026-06-17
- Weakness: CWE-122
Description
ImageMagick is free and open-source software used for editing and manipulating digital images. In versions below 7.1.2-19, a crafted image could result in an out of bounds heap write when writing a yaml or json output, resulting in a crash. This issue has been fixed in version 7.1.2-19.
Affected products
- ImageMagick: before 7.1.2-19 — fixed in 7.1.2-19
How to fix
Upgrade to a fixed version: ImageMagick 7.1.2-19. Check the vendor advisory for mitigations.
References
- https://github.com/ImageMagick/ImageMagick/commit/f86452a8aea37bf2b4bd36127f836dcc5f138b38
- https://github.com/ImageMagick/ImageMagick/releases/tag/7.1.2-19
- https://github.com/ImageMagick/ImageMagick/security/advisories/GHSA-5592-p365-24xh
- https://github.com/dlemstra/Magick.NET/releases/tag/14.12.0
Get alerted when CVE-2026-40169 or the next vulnerability affects your stack