What’s Vulnerable › Vulnerabilities

CVE-2026-40192: Pillow is vulnerable to a FITS GZIP decompression bomb

Description

Pillow is a Python imaging library. Versions 10.3.0 through 12.1.1 did not limit the amount of GZIP-compressed data read when decoding a FITS image, making them vulnerable to decompression bomb attacks. A specially crafted FITS file could cause unbounded memory consumption, leading to denial of service (OOM crash or severe performance degradation). If users are unable to immediately upgrade, they should only open specific image formats, excluding FITS, as a workaround.

Affected products

How to fix

Upgrade to a fixed version: python-pillow Pillow 12.2.0. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2026-40192 or the next vulnerability affects your stack