What’s Vulnerable › Vulnerabilities

CVE-2026-40212

Description

OpenStack Skyline before 5.0.1, 6.0.0, and 7.0.0 has a DOM-based Cross-Site Scripting (XSS) vulnerability in the console because document.write is used unsafely, which is relevant in scenarios where administrators use the console web interface to view instance console logs.

Affected products

How to fix

Upgrade to a fixed version: OpenStack Skyline 5.0.1. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2026-40212 or the next vulnerability affects your stack