What’s Vulnerable › Vulnerabilities
CVE-2026-40213
- Severity: high (CVSS 7.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-05-07 · updated 2026-10-26
- Weakness: CWE-863
Description
OpenStack Cyborg before 16.0.1 uses rule:allow (check_str='@') as the default policy for multiple API endpoints. This unconditionally authorizes any request carrying a valid Keystone token regardless of roles, project membership, or scope. An authenticated user with zero role assignments can complete various actions such as reprogramming FPGA bitstreams on arbitrary compute nodes via agent RPC.
Affected products
- OpenStack Cyborg: from 5.0.0 before 14.0.1; from 15.0.0 before 15.0.1; from 16.0.0 before 16.0.1 — fixed in 14.0.1, 15.0.1, 16.0.1
How to fix
Upgrade to a fixed version: OpenStack Cyborg 14.0.1, 15.0.1, 16.0.1. Check the vendor advisory for mitigations.
References
- https://bugs.launchpad.net/openstack-cyborg/+bug/2143263
- https://security.openstack.org/ossa/OSSA-2026-011.html
- https://www.openwall.com/lists/oss-security/2026/05/07/6
Get alerted when CVE-2026-40213 or the next vulnerability affects your stack