What’s Vulnerable › Vulnerabilities
CVE-2026-40224
- Severity: high (CVSS 7.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-04-10 · updated 2026-06-17
- Weakness: CWE-863
Description
In systemd 259 before 260, there is local privilege escalation in systemd-machined because varlink can be used to reach the root namespace.
Affected products
- systemd: from 259 before 259.3 — fixed in 259.3
How to fix
Upgrade to a fixed version: systemd 259.3. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-40224 or the next vulnerability affects your stack