What’s Vulnerable › Vulnerabilities
CVE-2026-40296: PhpSpreadsheet vulnerable to XSS in HTML writer via custom number format codes
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2026-05-06 · updated 2026-10-26
- Weakness: CWE-79
Description
PhpSpreadsheet is a pure PHP library for reading and writing spreadsheet files. The HTML writer skips htmlspecialchars escaping when a cell's formatted value differs from the original value. When a cell has a custom number format containing the text placeholder @ along with any additional literal characters (for example ". @", "@ ", or "x@"), the formatter replaces @ with the cell value and adds the extra characters, causing the formatted value to differ from the original and bypassing HTML escaping entirely. An attacker who can control the cell value and number format of an uploaded spreadsheet that is later converted to HTML and displayed to other users can achieve stored cross-site scripting. This issue is fixed in versions 5.7.0, 3.10.5, 2.4.5, 2.1.16, and 1.30.4.
Affected products
- PHPOffice PhpSpreadsheet: before 1.30.4; from 2.0.0 before 2.1.16; from 2.2.0 before 2.4.5; from 3.3.0 before 3.10.5; from 4.0.0 before 5.7.0 — fixed in 1.30.4, 2.1.16, 2.4.5, 3.10.5, 5.7.0
How to fix
Upgrade to a fixed version: PHPOffice PhpSpreadsheet 1.30.4, 2.1.16, 2.4.5, 3.10.5. Check the vendor advisory for mitigations.
References
- https://github.com/PHPOffice/PhpSpreadsheet/security/advisories/GHSA-hrmw-qprp-wgmc
- https://github.com/PHPOffice/PhpSpreadsheet/security/advisories/GHSA-hrmw-qprp-wgmc
Get alerted when CVE-2026-40296 or the next vulnerability affects your stack