What’s Vulnerable › Vulnerabilities
CVE-2026-40347: Python-Multipart affected by Denial of Service via large multipart preamble or epilogue data
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-04-18 · updated 2026-10-26
- Weakness: CWE-400
Description
Python-Multipart is a streaming multipart parser for Python. Versions prior to 0.0.26 have a denial of service vulnerability when parsing crafted `multipart/form-data` requests with large preamble or epilogue sections. Upgrade to version 0.0.26 or later, which skips ahead to the next boundary candidate when processing leading CR/LF data and immediately discards epilogue data after the closing boundary.
Affected products
- Kludex python-multipart: before 0.0.26 — fixed in 0.0.26
How to fix
Upgrade to a fixed version: Kludex python-multipart 0.0.26. Check the vendor advisory for mitigations.
References
- https://github.com/Kludex/python-multipart/releases/tag/0.0.26
- https://github.com/Kludex/python-multipart/security/advisories/GHSA-mj87-hwqh-73pj
Get alerted when CVE-2026-40347 or the next vulnerability affects your stack