What’s Vulnerable › Vulnerabilities
CVE-2026-40352: FastGPT: NoSQL Injection in updatePasswordByOld Leads to Account Takeover
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2026-04-17 · updated 2026-10-26
- Weakness: CWE-943
Description
FastGPT is an AI Agent building platform. In versions prior to 4.14.9.5, the password change endpoint is vulnerable to NoSQL injection. An authenticated attacker can bypass the "old password" verification by injecting MongoDB query operators. This allows an attacker who has gained a low-privileged session to change the password of their account (or others if combined with ID manipulation) without knowing the current one, leading to full account takeover and persistence. This issue has been fixed in version 4.14.9.5.
Affected products
- labring FastGPT: before 4.14.9.5 — fixed in 4.14.9.5
How to fix
Upgrade to a fixed version: labring FastGPT 4.14.9.5. Check the vendor advisory for mitigations.
References
- https://github.com/labring/FastGPT/commit/bd966d479fbe414d02679cf79f9eaaab3d100a2d
- https://github.com/labring/FastGPT/releases/tag/v4.14.9.5
- https://github.com/labring/FastGPT/security/advisories/GHSA-422w-vrfj-72g6
Get alerted when CVE-2026-40352 or the next vulnerability affects your stack