What’s Vulnerable › Vulnerabilities
CVE-2026-40384: Joomla! Core - [20260510] - Path traversal in com_media webservice endpoint
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-05-26 · updated 2026-07-24
- Weakness: CWE-22
Description
An improper validation of the search parameter of the com_media files API endpoint leads to a path traversal vulnerability.
Affected products
- Joomla!: from 4.0.0 before 5.4.6; from 6.0.0 before 6.1.1 — fixed in 5.4.6, 6.1.1
How to fix
Upgrade to a fixed version: Joomla! 5.4.6, 6.1.1. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-40384 or the next vulnerability affects your stack