What’s Vulnerable › Vulnerabilities
CVE-2026-4039: OpenClaw Skill Env applySkillConfigenvOverrides code injection
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-03-12 · updated 2026-06-17
- Weakness: CWE-74
Description
A vulnerability was determined in OpenClaw 2026.2.19-2. This vulnerability affects the function applySkillConfigenvOverrides of the component Skill Env Handler. Executing a manipulation can lead to code injection. It is possible to launch the attack remotely. Upgrading to version 2026.2.21-beta.1 is able to resolve this issue. This patch is called 8c9f35cdb51692b650ddf05b259ccdd75cc9a83c. It is recommended to upgrade the affected component.
Affected products
- OpenClaw: before 2026.2.21 — fixed in 2026.2.21
How to fix
Upgrade to a fixed version: OpenClaw 2026.2.21. Check the vendor advisory for mitigations.
References
- https://github.com/openclaw/openclaw/
- https://github.com/openclaw/openclaw/commit/8c9f35cdb51692b650ddf05b259ccdd75cc9a83c
- https://github.com/openclaw/openclaw/releases/tag/v2026.2.21-beta.1
- https://github.com/openclaw/openclaw/security/advisories/GHSA-82g8-464f-2mv7
- https://vuldb.com/?ctiid.350651
- https://vuldb.com/?id.350651
- https://vuldb.com/?submit.769580
Get alerted when CVE-2026-4039 or the next vulnerability affects your stack