What’s Vulnerable › Vulnerabilities
CVE-2026-40452: Apache IoTDB: Authorization bypass in /rest/v2/fastLastQuery exposes last-value data to unauthorized authenticated users
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-07-10 · updated 2026-10-25
- Weakness: CWE-284
Description
Incorrect Authorization, Improper Access Control vulnerability in Apache IoTDB. Authorization bypass in /rest/v2/fastLastQuery exposes last-value data to unauthorized authenticated users. This issue affects Apache IoTDB: from 1.3.5 before 1.3.8, from 2.0.5 before 2.0.10. Users are recommended to upgrade to version 2.0.10, which fixes the issue.
Affected products
- Apache Software Foundation Apache IoTDB: from 1.3.5 before 1.3.8; from 2.0.5 before 2.0.10 — fixed in 1.3.8, 2.0.10
How to fix
Upgrade to a fixed version: Apache Software Foundation Apache IoTDB 1.3.8, 2.0.10. Check the vendor advisory for mitigations.
References
- https://lists.apache.org/thread/04j2l6dosyboor4o2gvrzbrcrpllmh95
- http://www.openwall.com/lists/oss-security/2026/07/10/7
Get alerted when CVE-2026-40452 or the next vulnerability affects your stack