What’s Vulnerable › Vulnerabilities
CVE-2026-40476: graphql-php: Denial of Service via quadratic complexity in OverlappingFieldsCanBeMerged validation
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-04-17 · updated 2026-10-26
- Weakness: CWE-407
Description
graphql-go is a Go implementation of GraphQL. In versions 15.31.4 and below, the OverlappingFieldsCanBeMerged validation rule performs O(n²) pairwise comparisons of fields sharing the same response name. An attacker can send a query with thousands of repeated identical fields, causing excessive CPU usage during validation before execution begins. This is not mitigated by existing QueryDepth or QueryComplexity rules. This issue has been fixed in version 15.31.5.
Affected products
- webonyx graphql-php: before 15.31.5 — fixed in 15.31.5
How to fix
Upgrade to a fixed version: webonyx graphql-php 15.31.5. Check the vendor advisory for mitigations.
References
- https://github.com/webonyx/graphql-php/releases/tag/v15.31.5
- https://github.com/webonyx/graphql-php/security/advisories/GHSA-68jq-c3rv-pcrr
- http://www.openwall.com/lists/oss-security/2026/09/14/26
Get alerted when CVE-2026-40476 or the next vulnerability affects your stack