What’s Vulnerable › Vulnerabilities
CVE-2026-40477: Improper restriction of the scope of accessible objects in Thymeleaf expressions
- Severity: critical (CVSS 9.0 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-04-17 · updated 2026-10-26
- Weakness: CWE-917
Description
Thymeleaf is a server-side Java template engine for web and standalone environments. Versions 3.1.3.RELEASE and prior contain a security bypass vulnerability in the expression execution mechanisms. Although the library provides mechanisms to prevent expression injection, it fails to properly restrict the scope of accessible objects, allowing specific potentially sensitive objects to be reached from within a template. If an application developer passes unvalidated user input directly to the template engine, an unauthenticated remote attacker can bypass the library's protections to achieve Server-Side Template Injection (SSTI). This issue has ben fixed in version 3.1.4.RELEASE.
Affected products
- thymeleaf: before 3.1.4 — fixed in 3.1.4
How to fix
Upgrade to a fixed version: thymeleaf 3.1.4. Check the vendor advisory for mitigations.
References
- https://github.com/thymeleaf/thymeleaf/security/advisories/GHSA-r4v4-5mwr-2fwr
- https://access.redhat.com/errata/RHSA-2026:21772
- https://access.redhat.com/security/cve/CVE-2026-40477
- https://bugzilla.redhat.com/show_bug.cgi?id=2459344
- https://security.access.redhat.com/data/csaf/v2/vex/2026/cve-2026-40477.json
Get alerted when CVE-2026-40477 or the next vulnerability affects your stack