What’s Vulnerable › Vulnerabilities
CVE-2026-40504: Creolabs Gravity < 0.9.6 Heap Buffer Overflow via gravity_vm_exec
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-04-16 · updated 2026-10-26
- Weakness: CWE-122
Description
Creolabs Gravity before 0.9.6 contains a heap buffer overflow vulnerability in the gravity_vm_exec function that allows attackers to write out-of-bounds memory by crafting scripts with many string literals at global scope. Attackers can exploit insufficient bounds checking in gravity_fiber_reassign() to corrupt heap metadata and achieve arbitrary code execution in applications that evaluate untrusted scripts.
Affected products
- marcobambini Gravity: before 0.9.6 — fixed in 0.9.6
How to fix
Upgrade to a fixed version: marcobambini Gravity 0.9.6. Check the vendor advisory for mitigations.
References
- https://github.com/marcobambini/gravity/commit/18b9195598d9b944376754c6d1ad76e38a4adca1
- https://github.com/marcobambini/gravity/issues/437
- https://github.com/marcobambini/gravity/releases/tag/0.9.6
- https://www.vulncheck.com/advisories/creolabs-gravity-heap-buffer-overflow-via-gravity-vm-exec
Get alerted when CVE-2026-40504 or the next vulnerability affects your stack