What’s Vulnerable › Vulnerabilities
CVE-2026-40508: OpenEMR < 8.3.0 Stored XSS via Patient Portal Template Import Handler
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-08-19 · updated 2026-10-27
- Weakness: CWE-79
Description
OpenEMR before 8.3.0 contains a stored cross-site scripting vulnerability in the patient portal template import handler that allows authenticated attackers with Forms Administration permissions to upload template files containing arbitrary HTML or JavaScript. Attackers can inject malicious scripts through the template upload functionality, which are stored without sanitization and execute in the browser of any other Forms Administration user who views the template in the HTML editor.
Affected products
- openemr: before 8.3.0 — fixed in 8.3.0
How to fix
Upgrade to a fixed version: openemr 8.3.0. Check the vendor advisory for mitigations.
References
- https://github.com/openemr/openemr/commit/ba316dd1d8de1291102da3f20f64240729ff899e
- https://github.com/openemr/openemr/releases/tag/v8_3_0
- https://github.com/openemr/openemr/security/advisories/GHSA-5293-8q47-cf44
- https://www.vulncheck.com/advisories/openemr-stored-xss-via-patient-portal-template-import-handler
- https://github.com/openemr/openemr/security/advisories/GHSA-5293-8q47-cf44
Get alerted when CVE-2026-40508 or the next vulnerability affects your stack