What’s Vulnerable › Vulnerabilities
CVE-2026-40520: FreePBX api module Command Injection via GraphQL
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-04-21 · updated 2026-10-26
- Weakness: CWE-78
Description
FreePBX api module version 17.0.8 and prior contain a command injection vulnerability in the initiateGqlAPIProcess() function where GraphQL mutation input fields are passed directly to shell_exec() without sanitization or escaping. An authenticated user with a valid bearer token can send a GraphQL moduleOperations mutation with backtick-wrapped commands in the module field to execute arbitrary commands on the underlying host as the web server user.
Affected products
- FreePBX api: before 17.0.8 — fixed in 17.0.8
How to fix
Upgrade to a fixed version: FreePBX api 17.0.8. Check the vendor advisory for mitigations.
References
- https://github.com/FreePBX/api/blob/5f194e39a47e5481e8947f9694304d32724175f6/Api.class.php#L546C1-L554C3
- https://github.com/FreePBX/api/blob/5f194e39a47e5481e8947f9694304d32724175f6/ApiGqlHelper.class.php#L34C1-L36C136
- https://github.com/FreePBX/api/commit/5f194e39a47e5481e8947f9694304d32724175f6
- https://www.vulncheck.com/advisories/freepbx-api-module-command-injection-via-graphql
Get alerted when CVE-2026-40520 or the next vulnerability affects your stack