What’s Vulnerable › Vulnerabilities
CVE-2026-40525: OpenViking < 0.3.9 Authentication Bypass via VikingBot OpenAPI
- Severity: critical (CVSS 9.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2026-04-17 · updated 2026-10-26
- Weakness: CWE-636
Description
OpenViking prior to version 0.3.9 contains an authentication bypass vulnerability in the VikingBot OpenAPI HTTP route surface where the authentication check fails open when the api_key configuration value is unset or empty. Remote attackers with network access to the exposed service can invoke privileged bot-control functionality without providing a valid X-API-Key header, including submitting attacker-controlled prompts, creating or using bot sessions, and accessing downstream tools, integrations, secrets, or data accessible to the bot.
Affected products
- Volcengine OpenViking: before 0.3.9 — fixed in 0.3.9
How to fix
Upgrade to a fixed version: Volcengine OpenViking 0.3.9. Check the vendor advisory for mitigations.
References
- https://github.com/volcengine/OpenViking/commit/c7bb1676f4d037609f041bf39e4e2bd52e8f9820
- https://github.com/volcengine/OpenViking/pull/1447
- https://github.com/volcengine/OpenViking/releases/tag/v0.3.9
- https://www.vulncheck.com/advisories/openviking-authentication-bypass-via-vikingbot-openapi
Get alerted when CVE-2026-40525 or the next vulnerability affects your stack