What’s Vulnerable › Vulnerabilities
CVE-2026-40563: Apache Atlas: Script injection allows access to unintended data
- Severity: high (CVSS 8.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-05-04 · updated 2026-10-26
- Weakness: CWE-94
Description
Description: Improper Control of Generation of Code ('Code Injection') vulnerability in Apache Atlas Apache Atlas exposes a DSL search endpoint that accepts user-supplied query strings. Attacker can alter Gremlin traversal logic within grammar-allowed characters to access unintended data Affect Version: This issue affects Apache Atlas: from 0.8 through 2.4.0. For the affect version >= 2.0, vulnerability is only when Atlas is deployed with below non-default configuration. atlas.dsl.executor.traversal=false Mitigation: Users are recommended to upgrade to version 2.5.0, which fixes the issue.
Affected products
- Apache Software Foundation Apache Atlas: from 0.8 before 2.5.0 — fixed in 2.5.0
How to fix
Upgrade to a fixed version: Apache Software Foundation Apache Atlas 2.5.0. Check the vendor advisory for mitigations.
References
- https://lists.apache.org/thread/vd0oggmqxl2k1skm0z2f9p0plx7jhmfl
- http://www.openwall.com/lists/oss-security/2026/05/03/9
Get alerted when CVE-2026-40563 or the next vulnerability affects your stack