What’s Vulnerable › Vulnerabilities
CVE-2026-40684
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-04-30 · updated 2026-06-17
- Weakness: CWE-684
Description
In Exim before 4.99.2, on systems using musl libc (not glibc), an attacker can crash the connection instance when malformed DNS data is present in PTR records. This is caused by a dn_expand oddity in octal printing.
Affected products
- Exim: before 4.99.2 — fixed in 4.99.2
How to fix
Upgrade to a fixed version: Exim 4.99.2. Check the vendor advisory for mitigations.
References
- https://code.exim.org/exim/exim/commit/628bbaca7672748d941a12e7cd5f0122a4e18c81
- https://exim.org/static/doc/security/CVE-2026-40684.txt
- https://exim.org/static/doc/security/cve-2026-04.1/CVE2026-40684.assessment
- https://www.openwall.com/lists/oss-security/2026/04/30/21
- http://www.openwall.com/lists/oss-security/2026/05/01/11
Get alerted when CVE-2026-40684 or the next vulnerability affects your stack