What’s Vulnerable › Vulnerabilities
CVE-2026-40687
- Severity: critical (CVSS 9.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-04-30 · updated 2026-06-17
- Weakness: CWE-909
Description
In Exim before 4.99.2, when the SPA authentication driver is used with an adversarial SPA resource, there can be an out-of-bounds write that crashes the connection instance, or erroneous data processing that divulges data from uninitialized heap memory.
Affected products
- Exim: before 4.99.2 — fixed in 4.99.2
How to fix
Upgrade to a fixed version: Exim 4.99.2. Check the vendor advisory for mitigations.
References
- https://code.exim.org/exim/exim/commit/68b963b9f75ca27b38e1c0f8c87037990199f505
- https://exim.org/static/doc/security/CVE-2026-40687.txt
- https://exim.org/static/doc/security/cve-2026-04.1/CVE2026-40687.assessment
- https://www.openwall.com/lists/oss-security/2026/04/30/21
Get alerted when CVE-2026-40687 or the next vulnerability affects your stack