What’s Vulnerable › Vulnerabilities
CVE-2026-40711
- Severity: high (CVSS 8.0 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-06-26 · updated 2026-10-25
- Weakness: CWE-78
Description
Dell Dell Container Storage Modules, version(s) csi-powerstore v2.16.0, csi-unity v2.16.0, csi-powerflex v2.16.0, csi-powermax v2.16.0, contain(s) an Improper Neutralization of Special Elements used in an OS Command ('OS Command Injection') vulnerability. A high privileged attacker with remote access could potentially exploit this vulnerability, leading to Command execution.
Affected products
- Dell Container Storage Modules: before 2.15.2 or later; before 2.17.0 or later — fixed in 2.15.2 or later, 2.17.0 or later
How to fix
Upgrade to a fixed version: Dell Container Storage Modules 2.15.2 or later, 2.17.0 or later. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-40711 or the next vulnerability affects your stack